Discussione:
QMPlay2
(troppo vecchio per rispondere)
Fandango
2018-05-14 17:00:16 UTC
Permalink
***@debian:~/Scaricati$ QMPlay2
./QMPlay2: error while loading shared libraries: libpcre16.so.3: cannot open shared object file: No such file or directory
***@debian:~/Scaricati$
pino
2018-05-14 18:47:27 UTC
Permalink
Post by Fandango
./QMPlay2: error while loading shared libraries: libpcre16.so.3: cannot open shared object file: No such file or directory
segnalato:
<https://github.com/zaps166/QMPlay2/issues/175#issuecomment-388755694>

nell'attesa (di un provvvedimento), in *bubu* c'è chi mette a mano i lib assenti:
<https://askubuntu.com/questions/1035992/how-to-install-missing-dependencies-for-qmplay2-video-player-in-18-04-kubuntu>

<https://packages.debian.org/search?keywords=libpcre16-3>
Fandango
2018-05-14 18:59:19 UTC
Permalink
Post by pino
Post by Fandango
./QMPlay2: error while loading shared libraries: libpcre16.so.3: cannot open shared object file: No such file or directory
<https://github.com/zaps166/QMPlay2/issues/175#issuecomment-388755694>
<https://askubuntu.com/questions/1035992/how-to-install-missing-dependencies-for-qmplay2-video-player-in-18-04-kubuntu>
<https://packages.debian.org/search?keywords=libpcre16-3>
ci rinunicio, non voglio sputtanare la mia: Debian GNU/Linux 9.4
(stretch) nuova fiammante
pino
2018-05-14 19:10:58 UTC
Permalink
Post by Fandango
Post by pino
Post by Fandango
./QMPlay2: error while loading shared libraries: libpcre16.so.3: cannot open shared object file: No such file or directory
<https://github.com/zaps166/QMPlay2/issues/175#issuecomment-388755694>
<https://askubuntu.com/questions/1035992/how-to-install-missing-dependencies-for-qmplay2-video-player-in-18-04-kubuntu>
<https://packages.debian.org/search?keywords=libpcre16-3>
ci rinunicio, non voglio sputtanare la mia: Debian GNU/Linux 9.4
(stretch) nuova fiammante
in questo caso si tratta solo di sbattersi un pochino

ti ricordo che installare (cioè rendere nota, al packet manager, la sua
presenza) qualche lib che non è usata da altri prgm, non può danneggiare il
beneamato SO
Fandango
2018-05-14 20:37:51 UTC
Permalink
Post by pino
in questo caso si tratta solo di sbattersi un pochino
ti ricordo che installare (cioè rendere nota, al packet manager, la sua
presenza) qualche lib che non è usata da altri prgm, non può danneggiare il
beneamato SO
prova e riproca così mi sono giocato anche il mio amatissmo MPV :-(


***@debian:~$ sudo apt-get install mpv
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
mpv : Dipende: libva-wayland1 (>= 1.3.0) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
***@debian:~$
pino
2018-05-15 14:21:38 UTC
Permalink
Post by Fandango
Post by pino
in questo caso si tratta solo di sbattersi un pochino
ti ricordo che installare (cioè rendere nota, al packet manager, la sua
presenza) qualche lib che non è usata da altri prgm, non può danneggiare il
beneamato SO
prova e riproca così mi sono giocato anche il mio amatissmo MPV :-(
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
mpv : Dipende: libva-wayland1 (>= 1.3.0) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
meh... vorrei 1 soldo per ogni volta che ho letto quegli output

ormai le catene delle dipendenze sono come il DNA :]
e Debian stable non scherza, anzi :|

apt è DIO, ma bisogna conoscerlo altrimenti è meglio lasciare la stable e
passare alle derivate.
Ad es. la lista dei pacchetti bloccati (per scelta degli sviluppatori e/o tue
personali) ce l'hai con:
sudo dpkg --get-selections | grep hold
ma il brutto è che spesso le dipendenze dei bloccati non sono a loro volta
bloccate e quindi possono essere aggiornate e così spunta fuori qualche
problemino che dpkg non può risolvere perchè non può sapere qual'è la decisione
migliore da attuare per l'utente.

Sbloccare un pacchetto bloccato dai manutentori, significa rischiare molto
sulla stablità dell'OS, cmq è facile sbloccarlo:
sudo echo "NOMEPACCHETTO install" | dpkg --set-selections
e (ri)bloccarlo:
sudo echo "NOMEPACCHETTO hold" | dpkg --set-selections

Con un gestore-pacchetti come Synaptic è facile beccare e i pacchetti
danneggiati (da "Filtri personalizzati") e quindi reinstallarli.

C'è moltissimo da conoscere su dpkg...
...ma la vita è sempre più breve, e ripristinare il backup del desktop è sempre
più facile :]

Loading...